Skip to main content

Received empty response from Zabbix Agent at [X.X.X.X]. Assuming that agent dropped connection beca [Resolved]

I have a Zabbix configuration problem here in the company a few days ago. I'm having this error on the hosts page in the Settings portion. I have already done several tests, being:

  1. Agent and Server Ports Release (Firewall Disabled)
  2. I changed the settings of agent.config and server.config.
  3. I disabled SELINUX.

If you can help me thank you, I only need this communication so I can proceed with the finalization of the installation.

Error: Received empty response from Zabbix Agent at [X.X.X.X]. Assuming that agent dropped connection because of access permissions.

I already looked for solutions in google but I did not find answers

UPDATE: I noticed that the server apparently has some network problem. I have managed to install normal zabbix using yum in Centos 7. However, the server is taking too long to ping google.com and is missing the settings in the resolv.conf file.

I do not know what this network problem can be, I'm a beginner in linux and I'm having a bit of trouble correcting this without having to configure a new server.

UPDATE 2: I identified that the server did not contain the google DNS (8.8.8.8) configured in: /etc/sysconfig/network-scripts/ifcfg-eth0 so I added this registry and it solved the network problem, now it's ping google.com , before of this was only the internal DNS of the company. But the initial problem still persists and I think there may be some relationship with network configurations


Question Credit: Luis Fernando
Question Reference
Asked March 15, 2019
Posted Under: Network
48 views
2 Answers

After a few attempts, I identified that Zabbix Agent was in a different version of the zabbix server version. After making the change and leaving both versions the same, it was possible to communicate with Agent


credit: Luis Fernando
Answered March 15, 2019

Error is in agent config SourceIP=192.168.17.197 is same as Server but this should be IP addrees of the client for outgoing traffic. Try comment this out or use client IP addres instead.


credit: Quantim
Answered March 15, 2019
Your Answer